Slowdown after repeated executions

You can talk about anything related to LB Booster here, not covered in another category
k6dgw
Posts: 9
Joined: Thu Feb 24, 2022 12:34 am

Re: Slowdown after repeated executions

Post by k6dgw » Sat Mar 26, 2022 10:50 pm

Answer to previous question regarding Task Mgr: "I don't know, yet." I haven't found anything strange going on so far, I continue to search. TM presents a wealth of "data." Turning it into "information" is a different task.

But, I do have one more tidbit, for what it's worth: It is not necessary to restart Windows to restore the normal speed ... ending and restarting the LBB IDE will do the trick. Strangely, not every window in the app is affected the same way. One in particular paints part and then stops, and finally paints the rest. It has maybe a half dozen text boxes, 7 or so radiobuttons, and 3 or 4 ordinary buttons. I've constructed much more complex windows and haven't had a problem. Work continues

guest
Site Admin
Posts: 169
Joined: Tue Apr 03, 2018 1:34 pm

Re: Slowdown after repeated executions

Post by guest » Sat Mar 26, 2022 11:05 pm

k6dgw wrote:
Sat Mar 26, 2022 10:50 pm
It is not necessary to restart Windows to restore the normal speed ... ending and restarting the LBB IDE will do the trick.
This sounds exactly like a run-of-the-mill resource leak. The practical solution is to quit and restart the LBB IDE if the slow-down gets annoying.

k6dgw
Posts: 9
Joined: Thu Feb 24, 2022 12:34 am

Re: Slowdown after repeated executions

Post by k6dgw » Wed Mar 30, 2022 12:04 am

Yes, it has all the characteristics of a leak. Exiting and restarting is fine, way superior to restarting Windows. Maybe I'll find some time to track it down ,K6DGW>

Post Reply