Issues when OPEN RS232 serial port

Discussions about the Liberty BASIC language, with particular reference to LB Booster
Post Reply
Tasp
Posts: 16
Joined: Sun May 31, 2020 4:51 pm

Issues when OPEN RS232 serial port

Post by Tasp » Tue Feb 09, 2021 6:28 pm

The following errors when opening in LBB but works in LB.

Code: Select all

OPEN "com7:9600,n,8,1,ds0,cs0,rs" for random as #com
#com, CHR$(31);
CLOSE #com
end
This appears to be an issue with issuing the DS, CS and RS switches, they don't seem to be supported in LBB.

I'm unsure whether LBB ignores the RTS and CTS as I don't have the test equipment.
When testing with Hercules Serial monitor LBB seemingly ignores the DTR and RTS and transmits either way.

guest
Site Admin
Posts: 145
Joined: Tue Apr 03, 2018 1:34 pm

Re: Issues when OPEN RS232 serial port

Post by guest » Tue Feb 09, 2021 6:49 pm

Tasp wrote:
Tue Feb 09, 2021 6:28 pm
This appears to be an issue with issuing the DS, CS and RS switches, they don't seem to be supported in LBB.
This is documented in the Compatibility section of the LBB Help manual (item 9: "The syntax for serial port parameters is slightly different...").
I'm unsure whether LBB ignores the RTS and CTS as I don't have the test equipment.
LBB simply uses the built-in serial drivers in Windows (it has always puzzled me why LB4 doesn't, it may be that in the very early LB1 days Windows didn't come with serial drivers as standard). So how it behaves with the 'handshaking' signals will be whatever Windows does; there is some control available with the parameters listed here.

Post Reply